← Back to Upcase

Exuberant ctags: strange results on mac


(Jon Seidel) #1

I viewed the Drew Neil video on Vim & ctags - really terrific. I got everything configured just fine on my Kubuntu machine, but ran into problem on my MacBook. Drew mentions brew, but I use ports and there’s no exuberant-ctags port. So I built it from source (version 5.8) and everything seemed to work fine.

I ran it with

ctags -R .

and I get the message:

E432: Tags file not sorted

but then it eventually jumps to the method.

I’ve tried it with:

ctags -R --sort=yes .

and get the same error.


(Patrik Bóna) #2

As Drew said, ctags version shipped with OSX is useless.

See also: http://tbaggery.com/2011/08/08/effortless-ctags-with-git.html

If you don’t use brew, than you have to find another way how to install exuberant-ctags on your Mac.


(Jon Seidel) #3

Thanks @patrikbona; that’s why I installed exuberant-ctags from source…


(Kevin McGladdery) #4

What does the second line of your tags file say? It should start with something like !_TAG_FILE_SORTED.


(Patrik Bóna) #5

Yeah, I am sorry. Somehow I’ve overlooked that you had already built it…


(Jon Seidel) #6

NP, @patrikbona :=) @kmcgladdery I checked; no such second line. So I just wiped out everything, rebuilt the tags file, and now it works… Thanks!