Person =

When creating a new instance of person for a test is it a best practice to just lowercase the class name?

person =…)

Reading through most submissions it seems that is what everyone is doing.

I would aim to give a more descriptive name where possible, e.g. person_with_missing_surname, person_with_active_subscription, etc. It gives more context when reading the tests.


+1 to this.

It’s even easier when you use FactoryGirl and you’re able to use traits.