← Back to Upcase

Running bundle exec rails g db generates undefined method error


(Kim Khan) #1

To update an app I routinely run:
git pull
bundle install
bundle update
bundle exec rails g db
bundle exec rake db:migrate

Today I am getting the following error when I run bundle exec rails g db.
<top (required)>': undefined methodconfigure’ for Authentication:Module (NoMethodError)

Does anyone know how I should troubleshoot this error. I have already run git pull, bundle install and bundle update on the gems directories. Also, I have re-run bundle install and bundle update and then bundle exec rails g db on this app a few times with the same result.

Signed,
Stuck in rails g db


(Crispin Cornett) #2

What are you expecting rails g db to do?

Maybe you’re looking for:

bundle exec rake db:create

(Kim Khan) #3

No I usually use bundle exec rails g db with no problems.


(Geoff Harcourt) #4

Can you post a private gist of your Gemfile and config/application.rb?


(Kim Khan) #5

Not sure i can post this kind of info. How about if I share my screen via Skype? My skype id is kimkhan111.


(Crispin Cornett) #6

What about a gist?
https://gist.github.com/


(Kim Khan) #7

Well our repos are private so i am not sure if I can post to gist. I will have to ask first.


(Kim Khan) #8

Ok the solution was rather complex. It involved configuring some .pow files and the bash_profile files.

Also, had to upload an gemfile into my home directory and reference it in the bash_profile file.

I appreciate the support!!
~kk7