← Back to Upcase

VIM does not add new line at the end of file

Hello,

These are my Vim options: https://github.com/ralinc/dotfiles/blob/master/.vim/options.vim. Can someone tell me why Vim is not adding new line on save? That should be the default, right? I double-checked that I have not turned it off.

Thanks

The relevant setting is :set noeol. You can check if (and where) this is being set with :verbose set noeol. This will both list the current value (if set) and where it was last set (the file).

:verbose set noeol gives me nothing. I already searched all my settings files for that. I guess some plugin is overriding the default behavior, even though I use a quite a limited set of plugins. I would highly appreciate if someone can go over my vim config and point out the culprit :slight_smile: I’ve linked my dotfiles above.