← Back to Upcase

Clearance email host & port


(Jon Seidel) #1

I have an app running on my local machine for testing. App uses Clearance, newly-installed, and Postfix for SMTP relay. the app is running at 10.12.12.105:4000 (rails s -p4000 -b10.12.12.105). However, when I use the “forgot Password?” link, the email is created with a link of “localhost:3000…”

Why is this and how do I fix it?


(Pedro Moreira) #2

Hi @JESii, have you tried setting

config.action_mailer.default_url_options = { host: 'your_host' }

in your config/environments/development.rb (or the intended environment)?


(Jon Seidel) #3

Of course, @pedromoreira; I should have thought of that. Thanks for the reminder.


(Pedro Moreira) #4

No problem, glad to help :slight_smile: