← Back to Upcase

Generating missing paperclip styles on heroku


(Aaron Renner) #1

I am using Rails 3.2 and Paperclip 3.4.2 and just added a new style to one of the attachments on my model. I was able to run rake paperclip:refresh:missing_styles on my development machine, but I’m having issues running that command on heroku. Here is the output I get when I run heroku run rake paperclip:refresh:missing_styles

Regenerating BikePhoto -> photo -> [:med, :thumb]
rake aborted!
No such file or directory - /app/public/system/paperclip_attachments.yml
/app/vendor/bundle/ruby/2.0.0/gems/paperclip-3.4.2/lib/paperclip/missing_attachment_styles.rb:23:in `initialize'
/app/vendor/bundle/ruby/2.0.0/gems/paperclip-3.4.2/lib/paperclip/missing_attachment_styles.rb:23:in `open'
/app/vendor/bundle/ruby/2.0.0/gems/paperclip-3.4.2/lib/paperclip/missing_attachment_styles.rb:23:in `save_current_a
ttachments_styles!'
/app/vendor/bundle/ruby/2.0.0/gems/paperclip-3.4.2/lib/tasks/paperclip.rake:74:in `block (3 levels) in <top (requir
ed)>'
Tasks: TOP => paperclip:refresh:missing_styles
(See full trace by running task with --trace)

I saw you can set Paperclip.registered_attachments_styles_path in the documentation. I tried setting it to /tmp/config/paperclip_attachments.yml' and Rails.root.join('tmp','config','paperclip_attachments.yml') but have still received similar results.

Where do you store your paperclip_attachments.yml file on heroku and do you check it into source control?