← Back to Upcase

Linux machines for development


(Jon Seidel) #1

I’m wondering if anyone here uses a Linux desktop for development. I have for several years and in spite of the occasional frustrations, I’ve been very happy with it. However, the last week has been disastrous: I came back from a two-day conference, went to boot my Kubuntu 12.04 machine and it will no longer go into GUI mode. I’ve re-installed, re-configured, have a new motherboard /my local computer repair shop fried my old one ;-/, … and nothing works.

Does anyone here use any of the Linuces or is everyone on a MacBook these days? Thanks.


(Sean Griffin) #2

I think @djcp or @mikeburns (among others) might have a thing or two to say on this.


(Mike Burns) #3

Do you see any error messages? Can you log in from the console? What does /var/log/Xorg.0.log have to say? What happens if you run the kdm init script manually?


(Daniel Collis-Puro) #4

Howdy. I use Debian Testing (I used to use Kubuntu). I would try booting to a live CD to see where you get - it sounds like your video might be physically broken, with a reinstall I don’t see what else it could be.


(Jaroslav Janukevic) #5

Try doing this steps

  1. If you see a black prompt and can login, do that. Type dmesg check what that gives you and cat /var/log/Xorg.0.log. Try running sudo kdm or sudo startx
  2. Like @djcp mentioned, boot a live cd, if it works, it probably means that Kubuntu is broken or hdd failure.
  3. Mount your hdd in the live cd through nautilus/dolphin and navigate like @mikeburns says to /var/log/Xorg.0.log and paste it here.

I’m using Arch Linux with i3-wm on a ThinkPad L420.


(Jon Seidel) #6

Thanks everyone… I REALLY appreciate the support.

Short story: I installed Kubuntu 13.10 and now it all works (except for Chrome which keeps Aw, Snapping - minor detail).

Along the way I: booted using Knoppix LiveCd to examine things; re-installed the Nvidia drivers multiple times from multiple versions; ran the awesome Boot-Repair-Disk to clean up any grub problems; reconfigured partititions using gparted… It got to the point where I’d get a gui screen to login, but then it would black screen and back to the gui login prompt. I could always get to the console via Ctrl-Alt-F1 and start/restart kdm. I did much of what was suggested and could have responded with specifics, but fortunately don’t need to go there now.

Root cause? I think it was some incompatibility between the Nvidia drivers and the card I have. I’m still using the same video card (two monitors) and it works just fine now. Don’t know what cause the initial problem as it was working before I left for the conference and powered down the system.

I used to believe in the LTS versions, but 13.10 was so much better than 12.04 (e.g., configuring the two-monitor setup was a breeze compared to the 12.04 hoops I had to jump through) that I’ve changed my thinking. The reinstall was really easy given that I have /home mounted on a separate HDrive, so now I’ll just take the latest release when it’s time to move on.

One minor question: why is audio support on Linux (or Ubuntu or for me, anyway) such a nightmare? It keeps breaking and trying to add a USB headset was just an exercise in futility :=)

Thanks again…


(Jaroslav Janukevic) #7

Describe breaking and problem with adding.

Pulseaudio doesn’t detect your headset? Check in alsamixer or pavucontrol


(Jon Seidel) #8

Thanks; I’ll give that a try. Latest issue was that I plugged in a new USB/stereo headshet and it was detected. When I tested it under “Audio and Video Settings”, I heard the test sounds; howeer, no sound from the video I was watching or any other app.


(Jacqueline Homan) #9

I use Linux (Ubuntu 13.04). And zshell. I love zshell. I went with Ubuntu because it is Debian-based and therefore very stable. I have not had any serious problems (yet).


(Jon Seidel) #10

Here’s an interesting problem. The command

rails s -p3100 -b10.12.12.99

fails with the error

=> Booting WEBrick
=> Rails 3.2.13 application starting in development on http://10.12.12.99:3100
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2013-12-10 05:31:14] INFO  WEBrick 1.3.1
[2013-12-10 05:31:14] INFO  ruby 1.9.3 (2012-11-10) [x86_64-linux]
[2013-12-10 05:31:14] WARN  TCPServer Error: Cannot assign requested address - bind(2)

If I try to ping this address to make sure it’s not in use, I get:

From 10.12.12.238 icmp_seq=1 Destination Host Unreachable

where 10.12.12.238 is my machine’s address.

This used to work on my previous Kubuntu 12.04 configuration. I have a hardware firewall (SonicWall) with DHCP range of 10.12.12.200 - 10.12.12.250. I’ve checked and neither iptables nor ufw is running so that doesn’t seem to be the issue.

Any suggestions for where to start looking?


(Noah Clark) #11

Have you tried restarting and then running the command again to kill anything that might be running? What happens when you do just rails -s p3100 can you connect from 127.0.0.1? Do you get the same issues?

Those are the two most obvious suggestions. I agree it is weird though.


(Jon Seidel) #12

Yup… works just fine without the -b option and I’ve also tried from a fresh bash window.