← Back to Upcase

Vim-unimpaired causes crash?


(mciul) #1

I am using vim on an Ubuntu machine where I don’t have permission to update software (details of the system below)…

Until recently, I was running vim in tmux. It was working fine. I tend to leave my tmux session running for weeks with no problems. But a change to my user account required that I restart my tmux session. After I restarted, I could not run vim with my regular plugins without it crashing spontaneously after a few seconds or minutes:

$ vi vimrc 
Vim: Caught deadly signal SEGV
Segmentation fault

This would happen even if I did literally nothing at all after launching vim.

I’m not sure if it’s related, but I’d see this error every time I started up vim:

"vimrc" 417L, 13000C
Error detected while processing function <SNR>28_maps:
line    1:
E688: More targets than List items

I tried commenting out all the Vundle Plugin lines and then uncommenting each one on its own. From that experiment, it looks like vim-unimpaired was the problem - when it was the only plugin enabled, vim crashed immediately upon start, and when it was the only plugin disabled, vim seemed to work fine. It also appears that the error I was seeing comes from vim-unimpaired.

Can anyone tell me what’s going on? If there’s some old system incompatibility, I can talk to the sysadmins about it. But I don’t think they’ll agree to upgrade vim without being able to point to a specific problem. I’d really appreciate some insights. Thanks!

System info:

My dotfiles are at https://github.com/mciul/dotfiles

$ uname -a
Linux crunch 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 GNU/Linux

$ tmux -V
tmux 1.9

$ vim --version
VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Feb 10 2009 18:41:00)
Compiled by haejoong@capsa
Normal version with GTK2 GUI.  Features included (+) or not (-):
-arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent 
+clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments 
+cryptv -cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic 
-emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path 
+float +folding -footer +fork() -gettext -hangul_input +iconv +insert_expand 
+jumplist -keymap -langmap +libcall +linebreak +lispindent +listcmds +localmap 
+menu +mksession +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm 
-mouse_jsbterm -mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte 
+multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl +postscript 
+printer -profile -python +quickfix +reltime -rightleft -ruby +scrollbind 
+signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary 
+tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title
 +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo 
+vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim 
+xsmp_interact +xterm_clipboard -xterm_save 
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  system gvimrc file: "$VIM/gvimrc"
    user gvimrc file: "$HOME/.gvimrc"
    system menu file: "$VIMRUNTIME/menu.vim"
  fall-back for $VIM: "/ldc/app/Linux-i686/pkg/vim-7.2/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/include/gtk-2.0 -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/lib/gtk-2.0/include -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/include/atk-1.0 -I/ldc/app/Linux-i686/pkg/cairo-1.8.6/include/cairo -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/include/pango-1.0 -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/include/glib-2.0 -I/ldc/app/Linux-i686/pkg/gtk-2.14.7/lib/glib-2.0/include -I/ldc/app/Linux-i686/pkg/pixman-0.13.2/include/pixman-1 -I/ldc/app/Linux-i686/pkg/freetype-2.3.1/include/freetype2 -I/ldc/app/Linux-i686/pkg/freetype-2.3.1/include -I/ldc/app/Linux-i686/pkg/fontconfig-2.4.2/include -I/ldc/app/Linux-i686/pkg/libpng-1.2.16/include/libpng12 -I/ldc/app/Linux-i686/pkg/xorg-7.2/include   -I/ldc/app/Linux-i686/include  -g -O2  -I/ldc/app/Linux-i686/pkg/xorg-7.2/include       
Linking: gcc -L/ldc/app/Linux-i686/pkg/gtk-2.14.7/lib -L/ldc/app/Linux-i686/pkg/cairo-1.8.6/lib -L/ldc/app/Linux-i686/pkg/freetype-2.3.1/lib -L/ldc/app/Linux-i686/pkg/fontconfig-2.4.2/lib   -L/ldc/app/Linux-i686/pkg/xorg-7.2/lib   -L/ldc/app/Linux-i686/lib -L/usr/local/lib -o vim   -L/ldc/app/Linux-i686/pkg/gtk-2.14.7/lib -L/ldc/app/Linux-i686/pkg/cairo-1.8.6/lib -L/ldc/app/Linux-i686/pkg/freetype-2.3.1/lib -L/ldc/app/Linux-i686/pkg/fontconfig-2.4.2/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0   -lXt -lm -lncurses

(rderik) #2

Not sure if you have already fixed this, did you make any changes to the plugin?

I don’t use Vundle but I would go to ~/.vim/vundle/vim-unimpaired/

git status

to check if there are any modified files, or I would simply uninstall and reinstall the plugin.


(mciul) #3

Thanks for the suggestion. I didn’t have any modified files but I noticed there have been new updates to vim-unimpaired. I tried updating and running vim again - I still see the same error at startup, but it hasn’t crashed.


(mciul) #4

It did crash when I saved a file, though.