← Back to Upcase

RVM Path issue when I run RVM -V


(Chris Kuffo) #1

Hello - Hoping someone can help with this issue. Everytime i run rvm -v i receive this error.

Warning! PATH is not properly set up, '/usr/local/rvm/gems/ruby-1.9.3-p392/bin' is not at first place, usually this is caused by shell initialization files - check them for 'PATH=...' entries, 

My .bash_profile looks like this:

 export PATH=$PATH:/usr/local/rvm/gems/ruby-1.9.3-p392/bin:/usr/local/rvm/gems/ruby-1.9.3-p392@global/bin:/usr/local/rvm/rubies/ruby-1.9.3-p392/bin:/usr/local/rvm/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/sm/bin:/opt/sm/pkg/active/bin:/usr/local/bin:/opt/sm/pkg/active/sbina
export PATH=/usr/local/bin:$PATH
export PATH="/usr/local/bin:/usr/local/sbin:~/bin:$PATH" 

Can anyone point me in the right direction to resolve this. I have already tried the following.

rvm get stable --auto-dotfiles
rvm get head --auto-dotfiles
rvm get head
rvm get stable

Thanks in advance.


(Jon Seidel) #2

With rvm, you have to load it last in your bashrc (or bash_profile)… this is what I have in my .bashrc as the last line:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"  # This loads RVM into a shell session.

One thing to do is try starting your shell, then running the above command and see if that fixes things.