← Back to Upcase

"Tell Don't Ask" exercise doesn't exist

(Samnang Chhun) #1

@benorenstein

This page doesn’t exist: https://github.com/thoughtbot/tell-dont-ask-exercise

0 Likes

(Ben Orenstein) #2

That link works for me.

Is it possible that you weren’t logged in?

0 Likes

(Samnang Chhun) #3

No, I tried it again, but it still not working for me. You can see from this screenshot.

0 Likes

(Ben Orenstein) #4

Oops. Looks like permissions weren’t correct on that repo for some reason.

I just fixed it. Should be good now.

1 Like

(Charlieanna) #5

@ben the specs dont run. The gemfile doesnt have the factorygirls gem.

0 Likes

(Ben Orenstein) #6

I just ran them and they worked fine. The Gemfile doesn’t need factory_girl–it doesn’t use it.

Are you getting an error? If so, can you post it?

0 Likes

(rubylove.io) #7

I just checked and there is indeed an error on factory_girl.

@benorenstein in the spec_helper you are referencing active_model and factory_girl, but these are not in the gemfile. (pull request)

@charlieanna:

Add to your gemfile:

gem 'factory_girl'
gem 'activemodel'

Then:

bundle && rake
0 Likes

(Charlieanna) #8

I removed those requires and was able to run the specs. But I only was able to write the implementation and did not understand how to write the specs. Plus I think I am the only one to solve that question.

0 Likes

(rubylove.io) #9

@charlieanna - here is my quick solution: https://github.com/thoughtbot/tell-dont-ask-exercise/pull/6

0 Likes

(Charlieanna) #10

Oh Thanks. Even @samnang game his solution.

0 Likes