← Back to Upcase

VIMRC & Arrow Keys bein cray cray


(Adam White) #1

So, using the default dotfiles, I have no problem with arrow keys in Insert Mode, but when I use Ben’s dotfile as my .vimrc.local, my arrow keys to the ABCD thing, BUT when I :set nocompatible they work fine. The crazy part is, I have “set nocompatible” in my vimrc, so something else must be over-writing it, but I can’t figure out what it is.

I have eliminated the plugins as suspects. Halp!

Love & Rockets,
-Adam


(Adam White) #2

To add, I think maybe that the .vimrc.local may not be recognizing the “set” correctly. I tried to change my background and it definitely isn’t recognizing “set background=dark” but when I type the command, everything is dandy.


(Adam White) #3

I resolved this by removing “set noesckeys” from lines 183 and 221.


(Daryll Santos) #4

Hey man, what configs have you done to change @benorenstein’s dotfiles? I also shamelessly stole them and added stuff like @kylefiedler’s CSS snippets and remapped the leader command to . I got a lot from this article in r/vim recently: http://sheerun.net/2014/03/21/how-to-boost-your-vim-productivity/


(Adam White) #5

I haven’t added anything yet, but thanks for that article, it’s awesome.


(Geoff Harcourt) #6

In Xterm, the arrow keys are sent with an escape sequence, so noesckeys prevents this from working in insert mode. The advantage of noesckeys is that you will get a shorter delay (actually no delay) between when you press escape and when vim exits insert mode.

You can use ttimeout and other settings to reduce the delay while vim waits to see if the escape key was part of a sequence or not while retaining the ability to use the arrow keys in insert mode.

Check out h esckeys and h ttimeout in vim for some more info on this behavior.